Microsoft Office 365 Outage
Incident Report for Magellan from CSE
Resolved
Microsoft believe they have resolved the sign-in issue.

https://twitter.com/Office365Status/status/862406470121533440
Posted about 2 years ago. May 10, 2017 - 21:50 BST
Identified
There is currently an issue logging into office 365 accounts.

More information posted by Office 365 status twitter here https://twitter.com/Office365Status/status/862396348569706496
Posted about 2 years ago. May 10, 2017 - 21:03 BST