Magellan Login Issue
Incident Report for Magellan from CSE
Resolved
This issue has been resolved.

One of the hosting virtual machines had a degraded performance and wasn't responding to some of the login requests. This VM has been replaced.
Posted over 2 years ago. May 31, 2017 - 13:51 BST
Investigating
We are investigating an issue with and unexpected error trying to log into Magellan.
More Information will be available ASAP.
Posted over 2 years ago. May 31, 2017 - 13:31 BST